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1. INTRODUCTION TO BEAMS 

1.1 THEORY 

 Beam elements in Femap are powerful elements yet take special care to ensure they are used properly. The NX Nastran 
Theoretical Manual says it best:  

“Although it is one of the simplest of structural elements and one that is well known to everybody, the beam has 
been a troublesome element in the development of NASTRAN, due to difficulty in selecting the properties that it 
should have. In retrospect it seems clear that the versatility of the beam concept is the cause of the difficulty.” 

  

In practice, only two nodes and a cross section are required to create an element. Beams each have a unique coordinate 
system— the X-axis is down the length of the beam from End A to End B, and the Y-axis is defined by the user in the 
beam definition dialog.  Each end of a beam has 6 degrees of freedom and any of these 6 can be released at either end.  
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Before jumping into the model it is important to understand the terminology used in Femap, it is easy to get lost in the 
jargon of beam elements. The diagram below is from the NX Nastran Element Guide and provides some guidance on the 
gobbledygook of beam terminology. 

The important terms to remember today are: 

 

Beam End A: The end of the beam at the first 
node selected 

Beam End B: The end of the beam at the 
second node selected 

Plane 1: Plane through the beam defined by 
the local Y axis and X axis 

Plane 2: Plane through the beam defined by 
the local Z axis and X axis 

Combined Stress: Sum of the Axial, shear, 
and bending stress (note: torque is not 
included) 
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1.2 BEAM MESH 

Equations for beam elements are developed from classical beam theory (e.g. Timoshenko Beam Theory). Being built on 
classical beam theory means a simulation engineer can perform a hand calculation and validate the model fairly easily. It 
also means that beams are non-isoparametric elements – that is, one doesn’t need to consider mesh density in the 
traditional sense. One beam element will give you accurate stress and deflection results between two nodes in a static 
analysis. Of course, additional elements can be added if more resolution is desired in the deflection. The image below 
shows deflection contoured over a simple cantilever beam model. The maximum deflection is the same between the 1 
element and 10 element model, but the 10 element model shows the bending contour and intermediate stresses more 
accurately. 

1-element beam: 

 

10-element beam 

  



 

 

 
Beams: a sneaky, simple and complex element 2016 

Predictive Engineering Proprietary Document, Please Do Not Copy or Distribute Page 7 of 28 

Another situation where more elements should be considered when using beam elements is in vibration analysis. One 

element may not be enough to capture all modes of vibration of a beam. Let’s consider a simply supported beam . 

With two elements there are a total of 4 modes, with very little definition in the actual shape of the mode: 

 

If we jump up to ten elements, there is a lot more resolution in the mode shape and we can see the higher order modes 

which didn’t appear in the results for the two element beam model: 
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Back to stresses-- what about the Pt1 to Pt4 stresses? Beam stresses are calculated at the stress recovery points defined 

in the beam cross section definition dialogue. If stress values at different points are desired these can be changed in the 

beam property definition editor. 

If the stresses at a stress recovery point are desired it can be plotted by selecting the combined stress at the selected 

beam end and stress recovery point. The combined stress includes the bending moment in PL1 and PL2, axial and shear 

stress in PL1 and PL2. It does not include the torsional stress.  
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By now you may have noticed that there is no von Mises Stress output vector for beam elements. A lot of the time 
engineers are used to looking at von Mises stress in their analysis—so what stress result should you look at for guidance 
in your design? We can take a look at our simple cantilever beam model for answers again!  

If there is minimal torsional loads the Beam End Max Combined Stress is equal to the von Mises stress, but if there are 
torsional forces you could be severely under-predicting your stresses. 

-Y Force Only -Y Force, and Moment about X-axis 
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Sometimes the torsion in beam elements can affect your analysis in unexpected ways. One case to be careful of is thin 
walled open section beams. In these beams the shear center and centroid are not coincident. If a downward force is 
applied to the centroid, it would cause torsion in the beam (and we know from the previous discussion that beam 
elements do not like torsion. To avoid this, Femap applies a shear center offset to the element. This is important-- the 
load is always applied through the shear center, regardless of what this offset is.  

Note: To achieve this offset, numerically a MPC is added to the beam to offset it from the connected nodes. This could 
cause issues in nonlinear analysis so a shear center offset should be avoided for nonlinear work. 

 
 

With “Thickness / Cross Section” activated one can see that the 
beam is offset and the load is applied through the shear center Shear Center offset boxed in green 
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1.3 LIMITATIONS 

It should be apparent by now that there beams excel in some areas and are limited in others. Some things to keep in 
mind when considering using beams: 

 Structures that are dominated by torsional stresses may be better represented with plate elements 

 In non-linear analysis, adding a neutral axis offset may cause unpredictable results.   

 

 

 

 

1.4 APPLICABILITY 

Beam elements can be very useful for the following use cases: 

 Long, slender structural bodies 

 Bolted Connections 

 First-pass analysis to determine beam sizing or geometry 

 Structures with very low torsion 
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2. BOLTED CONNECTIONS  

Now it’s time to put some beams to work. One of the most common uses for beam elements is modeling bolted 
connections. One approach is to add MPCs to the holes and use a beam element to connect the MPCs.  

 

Our example model is made up of plate elements and is ready for some bolted connections: 
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3.1 FASTENER API 

Let’s use an API to help us out with our bolted connection. This API is useful for connecting two holes in plate elements, 
and requires a bolt material to be created prior to starting the API. The Hole To Hole Fastener API is accessed in the 
Custom and User Tools menu, Custom Tools > Meshing > Hole To Hole Fastener. 

This brings up a dialog box where one can simply select the curves on the first hole, then select the curves on the second 
hole, and Femap will create your MPCs and a beam element connecting the two.  
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With the bolts created we can turn on Thickness and make sure everything looks good: 

 

 

You may have notices we never set a bolt size when creating these bolts. This API measures the diameter of the curves 

and creates a beam element the same size. If different size is desired, the radius can be changed in the property 

definition.  

 

The boundary conditions have already been applied, so this is ready to analyze!  
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3.2 CONTOUR ARROWS 

One way to query forces on the bolts is to use contour arrows. This is selected in the post-processing toolbox.   

The setup is shown below on the left. Start at the top and move your way down the options.  
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While this is convenient to visualize forces on one or two bolts it can get overwhelming as the number of bolts increases: 
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3.3 EXPORTING SHEAR AND AXIAL FORCE TO CSV 

Most analysts are going to want these bolt forces in a table format. Luckily, Femap provides a straightforward way to 

drop these results into a .csv file. Prior to the below steps, ensure that the data you want to export to a table is 

contoured over the model.  

 Turn on the Data Table (Tools > Data Table). 

 Select  List > Output > Contoured Results to Data Table 

 

 

 

 

 

 Click the Save button, and save your results to a .csv file 
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4. LINKAGES WITH BEAMS 

Another common use case for beam elements is linkages. Beam elements allow you to release any of the 6 degrees of 
freedom at the ends, which will allow the beam end to move as desired.  

Let’s start off with the farm equipment model shown below: 
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Let’s say there is a new intern in the office, and they built this model, analyzed it, and sent it your way. The customer is 
really interested in the stresses in the yellow beams shown below: 
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4.1 FREEBODY DIAGRAM ON BEAMS 

First, let’s take a look at the free body diagram at one end of the yellow beam: 

 

The forces seem reasonable, but notice the large moment about the X-axis. This beam is supposed to rotate freely, so 
you know that there should be no moment about the rotational axis. 
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4.2 BEAM ENDS, END RELEASE 

In order to let the beam rotate freely along the x-axis, the ends need to be released in the RX direction. Note that the 
beam releases are with respect to the local beam coordinate system, this beam just happens to be lined up with the 
global coordinate. 

Open up Modify > Update Element > Beam/Bar Releases  

 

As discussed before, there are 6 dof for each beam end which can be 

 released. For example, selecting the End A, TX box will allow End A of 

 the beam to translate in the beam’s X (axial) direction.  

 

You can display beam End A and End B by selecting View > Options, and  

select Element – Directions, then “Show Direction” in the upper right  

corner. 
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With element directions turned on you can see an arrow head on each element. The arrow head is located on End B, and 
pointing from beam End A to End B.  

 

We want the outer end of the beam to be able to rotate (the end on the left side of the image), so we will release beam 
End A 
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On the other side the beam is flipped around, with the arrow head on the right side of the beam in the image.

  

Here we will release End B in RX to allow it to rotate on the end on the right side of the image. 
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With the ends properly released we can go back and take a look at the free body diagram to ensure the loads make 

sense. 

 

With the beam ends released there is no moment about the x-axis of the beam, so it looks like the problem has been 

corrected.  
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4.3 ADVANCED POST FOR FULL FIELD STRESSES 

For further investigation we can go back to the Advanced Post tool. 

The image below shows the Y Direction Shear Stress due to torque when the beam end is not released 
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The image below shows the Y Direction Shear Stress due to torque when the beam end is released, and as expected 

there is zero stress due to torque.  
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5. SUMMARY 

The takeaway here is to keep track of what you are asking Femap to do. If a load is applied directly to a beam element, 
one must keep in mind that there will be no torsional bending because the load is always applied through the shear 
center. If another load condition is required, one can manually apply a load to the centroid via rigid element, but any 
deflections will not be shown visually in the post processing. If an open section beam is to be loaded away from the shear 
center, a more transparent model can be created by using plate elements instead of beam elements.  
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6. SEMINAR Q & A  

Q: Why not release both End A and End B for a beam that sits in bearings on both ends? 

While this does make intuitive sense, it doesn’t work out numerically in the FEA solver. If both ends are released 
there is no stiffness in the local RX direction, and the beam will be under-constrained.  

 

Q: Is there a way to make the API use the same bolt property each time instead of creating a new property for each 
beam?  

Yes! There are many bolt APIs like this with different options. See www.appliedcax.com for more APIs. Check out 
“Automatic Spider and Beam Creator” for an example of a bolt API with more options.  

 

Q: What is the difference between Max Combined Stress and von Mises Stress?  

Max combined stress is calculated by combining all beam stresses except torsion. Von Mises includes all of those 
stress components and adds torsion. That is why the example with a force only showed that Max Combined stress 
matched up with the Von Mises stress, while when a torque was applied to the beam, Von Mises stress was much 
higher than Max Combined stress.  

 

 

http://www.appliedcax.com/

